Question

pottymonster on Thu, 08 Jun 2017 15:08:29


Hi,

I have an issue here that I haven't been able to find a response to that makes sense to me. 

I am using Windows 10, and Office 2010. 

Computer A: when I go to a Sharepoint site and open a Word document and go to Save as, it points me back to the Sharepoint directory. 

Computer B: when I go to a Sharepoint site and open a Word document and go to Save as, it just points me back to my Default file location as configured in File > Options > Save

With files from local directories (C:\New Folder for example), both computers always point back to the location the file was opened from for the Save as dialog starting point.

How do I standardize the Save as behavior so that it does that with Sharepoint? It works on some of my computers out of the box, but on others it just always uses the Default file location for Sharepoint files even though it works fine for local files.

Thanks!


Sponsored



Replies

croute1 on Thu, 08 Jun 2017 17:27:39


Hi pottymonster- that name scares me for some reason ;)

Have you tried repairing Office?

pottymonster on Thu, 08 Jun 2017 19:38:20


Hi croute1,

The name strikes fear in the hearts of many. :P

I've tried repairing, I've tried reinstalling. I even reimaged the laptop and the issue remained present on that particular laptop. I haven't tested reimaging any of the other machines that exhibit the behavior, but I can confirm that repairs and reinstalling don't fix it.

My question can be boiled down to availability of the site I believe. As I understand it, Office will open the save as dialog on the last used directory if the location is available. This is why it always works on a local folder. I thought at first that maybe the Sharepoint site was unavailable to be saved to, but I can navigate to it manually in the dialog. Also, if it was unavailable I would expect some kind of error appearing that the document was now inaccessible.

I'm wondering if there is some way to force the behavior?

croute1 on Thu, 08 Jun 2017 19:59:11


Hmmm... and it happens with all types of documents and different libraries? How's your server health/latency? (don't think that's it, but just checking). My guess is your program settings in Office. Go to file > options > save. make sure the "save to computer by default" is unchecked. You may need to tweak other settings there as well.

I'm in '16, but hopefully it's similar in your version:

pottymonster on Fri, 09 Jun 2017 13:10:19


The server and connection to it is fine. I also thought that might be the problem, except that the problem is only currently related to two computers that I'm aware of, and I can move them around the building and the problem follows only them (they're laptops) whether wired or wireless. Problem is with all documents in all sharepoint libraries.

Unfortunately, Office 2010 doesn't have the save to computer by default option. It has a 'Default file location', which is pointed to the local documents library. I tried setting it blank, but it doesn't accept that. The default file location also doesn't affect the save as functionality when dealing with local documents, it only applies when it's a brand new document (not saving a copy of an existing one).

There was a registry hack for office 2003 and 2007, I can't find it right now, but it didn't work when modified for office 2010 from my testing.

What I find particularly odd is that the problem continued on the laptop after reimaging it, as though Sharepoint has a log of the MAC address or a GUID and has rejected it.

pottymonster on Tue, 13 Jun 2017 17:29:37


http://www.shulerent.com/2011/09/20/undocumented-behavior-of-office-2010-word-save-as-dialog-with-sharepoint/

Here is someone who describes exactly what I'm looking for, and encounters the exact same problem. Unfortunately, he just chalks it up to being an unreliable feature.

I feel as though there isn't going to be a solution to this.