Question

Linknoid on Sat, 16 Apr 2016 12:55:01


I have Update 1 installed, and when I run Update 2 installer, it ends up at this screen, nothing to install, "Update" button isabled.  I tried running normally and "Run as admin".

OK, I tried to attach an image, it won't let me until my account is verified, so I'll try to describe it:

Community 2015

Single tab "Features", underlined in blue.

Under "Select features", it has a single line:

"Visual Studio 2015 Update 1" with a checked checkbox before and a blue circle info link after.  Line is disabled.

The rest of that box is empty.

"Setup requires up to 11 MB across all drives".

"Update" button with privilege elevation icon.  Button is disabled. 


Additional information:

Running Windows 7, all updates up to date.

Running Microsoft Security Essentials, definitions up to date.

Spybot Search and Destroy immunizations up to date as of last week.


Sponsored



Replies

Alexandros Zepidis on Sat, 16 Apr 2016 23:55:22


I'm having the exact same problem with Visual Studio 2015 for Web when trying to install update 2. I proceeded in uninstalling/reinstalling Visual studio and nothing appears to be selectable to continue the installation of the update. 

Sara Liu on Mon, 18 Apr 2016 01:46:26


Dear Linknoid,

Welcome to the MSDN forum.

How did you install the update 2 installer? If you used the web installer, I recommend you download a healthy ISO file of update 2 from https://www.visualstudio.com/downloads/download-visual-studio-vs and use it to install. Before installation, please use the FCIV.exe tool http://blogs.msdn.com/b/heaths/archive/2011/03/25/verify-the-iso-checksum-for-visual-studio-2010-service-pack-1-before-installing.aspxto validate the SHA-1 value of the ISO file, the value of Visual Studio 2015 update 2 is “269FA5FE823263718DA056D465BF8EB19C87ECD8”. Only this 2 values are the same, that means the ISO file is integrity and you can use it to install.

If you already used the ISO to install, please use the FCIV.exe tool to check the integrity of the ISO file, in case the ISO file is corrupted and make the installation failed.

There have some installation notes you should have a look at as following:

1. Make your windows update up-to -date, since your OS is Windows 7, please upgrade to Windows 7 SP1, the VS 2015 is support on the Windows 7 SP1

2. Disable any anti-virus software on your computer during installation, in case it prevents the installation

3. Run the installer as administrator

If the issue still persists, I need your help to collect the installation log and the screenshot that you mentioned. Please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

Best regards,

Sara

Alexandros Zepidis on Mon, 18 Apr 2016 03:05:59


Hi, 

I have found a solution although I'm not quite sure what it was because I tried numerous things.

First of all, the installation of VS is from a healthy ISO as found at the visualstudio.com site on a Windows 10 machine. The PC is well maintained without any extra bundle-ware that could cause problems (like antivirus etc).

After uninstalling and re-installing VS and rebooting, what made the difference in my case was that I proceeded and uninstalled a lot of VS plug-ins and extras added with the new installation.

Although I don't really remember which removal made the difference it was one of them that was obviously blocking the installation of Update 2.

I removed components such as:

HDInsights,

Application Insights,

Some Azure components (like Data Lake, Data Factory etc)

and pretty much any extension/component I wasn't supposed to use.

And voila: the Installation options on the Update 2 appeared and I upgraded successfully.

It was only after their removal that the update worked.