ASR Re-protect Fails

Category: microsoft azure site recovery

Question

Mohammad Thahif on Mon, 23 Sep 2019 14:57:23


Hello,

When I enable re-protect it fails with below error. Please help. 

Error ID: 

The master target server 'rMXXXXXX' has virtual disk '[DC3_Bronze_Vol_02_NonProd_02] XXXXUAT056/XXXXUAT056.vmdk' and virtual machine 'XXXXUAT055' has virtual disk '[DC3_Bronze_Vol_03_NonProd_03] XXXXUAT055/XXXXUAT055.vmdk' both having the same disk UUID '6000C294-ab36-423d-9b71-50d3c8d960cb'. Disks with the same UUID cannot be attached to the master target server.

Have tried moving one of the VM to different datastore, but still the same error. 

Please help.

Replies

Rohan Islam on Tue, 24 Sep 2019 12:28:39


Please check from VMWare level first to verify why and how the 2 vmdk files got same UUID

Thanks

Mohammad Thahif on Wed, 25 Sep 2019 14:37:11


Below steps solved the issue.

Identified conflicting disk UUIDs and updated new disk UUID on problematic VM.

Detach/re-attach all the disks. 

post which, re-protect worked fine.