"Profile test" is disabled after upgrading to Windows 8

Category: visual studio test

Question

CadErikWork on Wed, 29 May 2013 14:23:01


My test explorer was working flawlessly before my windows 8 enterprise upgrade but now, the "Profile test" option is disabled. Everything else is working correctly, I can also start profiling sessions without any glitch. I tried with VS 2012 update 2 and also Update 3 RC1 and no change.

Replies

Amanda Zhu on Thu, 30 May 2013 02:33:35


Hello,

Thank you for your post.

Whether you are working with ReSharper? This is a thread with the similar issue:

http://social.msdn.microsoft.com/Forums/en-US/vstest/thread/5a61bfd7-019a-4e5c-a12a-04af4c693896

It seems that the issue may reproduce when ReSharper is enabled.

If it is in this case, I suggest that you try the following suggestions:

You could locate to the IDE folder then run these commands, or you can set path to the system environment.

C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE

Devenv.exe /SafeMode: Launches the IDE in safe mode loading minimal windows.

Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

Devenv.exe /ResetAddin: Removes commands and command UI associated with the specified Add-in.

Devenv.exe /ResetSkipPkgs: Clears all SkipLoading tags added to VSPackages.

After these, you can create a new test project and a new test to avoid if there’re any problems of the old settings. If still has no help, I suggest that you try repairing your VS.

Best regards,

CadErikWork on Thu, 30 May 2013 14:34:20


Thanks for your help. I tried all these commands, I tried disabling my addons, and even reinstalling Visual Studio 2012. No luck with any of these, I ran devenv with /log and I found the following exception. The file is there, so I am not sure which dependency would fail.

Could not load file or assembly 'Microsoft.VisualStudio.TestWindow.Core, Version=11.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
         C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO 11.0\COMMON7\IDE\EXTENSIONS\MICROSOFT\UNIT TEST EXPLORER\PROFILER\Microsoft.VisualStudio.TestWindow.Profiler.dll

CadErikWork on Thu, 30 May 2013 15:21:47


I fixed the issue by deleting all files in C:\Users\...\AppData\Local\Microsoft\VisualStudio\11.0\ComponentModelCache

Amanda Zhu on Fri, 31 May 2013 01:37:42


Hello,

Glad to see this issue has been resolved and thank you for sharing your solutions & experience here. It will be very beneficial for other community members who have similar questions.

Best regards,