Extremely slow perfornance on Azure VM's

Category: azure vm

Question

NMoore36 on Mon, 09 Feb 2015 09:39:56


We have sold our first 2 small Azure real world implementations and have set them all up and are now getting hit with extremely bad feedback from the clients over performance.

One of them is setup as the following:

  1.       Domain Controller – A2
  2.       Terminal Server – A3

The terminal server is on an A3 plan (as it’s only a micro client of 2-4 concurrent users) and is horrendously slow. It takes 10-15 seconds to load websites in Internet Explorer (even during testing today it took 10 seconds to load sites such as Telstra's site or Sydney Morning Heralds site).

It also takes on average 8 seconds to load Microsoft Excel (without even loading a file). This is a vanilla install of Excel 2013 on Server 2012 R2 with the RDS role. We initially advised the client they should be fine on an A2 plan, however after they first complained about speeds, we moved them to A3 which made next to no discernible difference (and task manager is showing the machine not even coming close to using any resources).

Performance testing  is showing that the disk subsystems are slower than our desktop SATA machines – which could be related (which a quick Google search of “Azure slow disk io” shows that we aren’t alone here).

Our team here have run up an Amazon instance (with smaller specs than the A3 plan) and it is lightning fast doing the exact same things. We have also benchmarked on another Virtual Machine host that we used to use as we still have clients there from before we decided to start selling Azure and they are also lightning fast doing the same things.

In this particular case, the speeds they are getting are much, much slower than the 5 year old server that was replaced, which doesn’t bode too well for us unfortunately.

Another one of our clients other clients has exactly the same slow performance on their RDS server, especially around browsing the Internet. Speed tests on both show huge amount of speed (i.e. 500Mbit +) but daily usage doesn’t reflect that at all. It honestly feels like the Internet is operating at dial up speeds.

We've purchased a developer support pack and tried to lodge support instances, however it keeps crashing at the end of creating the request saying "Cannot log a support request at this time. Please contact Microsoft via phone and lodge an Azure request". We try calling via phone and they say they can't lodge them and we have to do it online.

We're desperate here for some help. Can anyone point us in the right direction?

Our guys have spent about 20 hours on this issue and everything points back to the Azure VM's just being super slow compared to other cloud providers (Amazon etc).


Replies

Sowmya K R on Mon, 09 Feb 2015 10:31:56


Hi,

Suggest you to look for the various Azure VM Sizes available and their corresponding Memory specifications and expected IOPS.

https://msdn.microsoft.com/library/azure/dn197896.aspx

Hope this helps !

Regards,

Sowmya


NMoore36 on Mon, 09 Feb 2015 10:48:15


Sowmya,

Thanks for your reply. We are more than aware of the memory specifications and expected IOPS. 

The performance we are getting out of these servers is far from what you would expect given their memory/CPU. I'm not talking in terms of a few percent variances, I am talking about big differences. It takes 2 seconds to load www.telstra.com on a test Core 2 Duo with 1Gb of RAM in our office and 10 seconds on an Azure VM.

This is not normal performance we are talking about here.

Regards,

Nigel

Sowmya K R on Mon, 09 Feb 2015 11:51:41


Hi,

In order to diagnose further we might require further more information including Subscription ID and Log Reports.

Microsoft respects Customer Data Privacy and hence would not recommend you to share the same on public forum.

Request you to log a support ticket for the same

http://azure.microsoft.com/en-us/support/options/

Regards,

Sowmya

NMoore36 on Mon, 09 Feb 2015 12:03:00


Hi Sowmya,

As mentioned in my original post, we have already tried this multiple times however it appears that this system is currently broken. We receive an error message advising us to contact Microsoft via phone for Azure support. When we try calling, we get the run around telling us the only way to submit a request is through that same webpage, which is broken.

Please assist.

Regards,

Nigel

Sowmya K R on Thu, 19 Mar 2015 15:22:03


Hi, 

On the forums we will be unable to get the details of your Virtual machines and assist you in getting your VM back into services, as this is beyond the scope, So I strongly recommend you to open up a support ticket as I see the scenario or the issue that you are facing needs a deeper troubleshooting. 

Regards,

Sowmya