Question

enitesh on Mon, 13 Feb 2017 16:50:46


Hi All,

I am working on SharePoint 2013 search. I am facing issue with search where some of the pages in a publishing site are not displayed in search

1. The page is displayed as below

2. The page is present in document library

3. The page is crawled as in crawl log

4. When searched, the page is not searched

The page is checked in and published

I also tried below

1. Reindex document library "Pages"

2. Reindex site


3. Reset the index in Search Admin (Central Admin)

4. Do full crawl

Any inputs would be helpful


Nitesh Earkara


Sponsored



Replies

Achiever SP on Mon, 13 Feb 2017 18:44:32


After the Full crawl, perform an incremental crawl and check the search results. 

enitesh on Mon, 13 Feb 2017 19:08:17


Hi, I already have continous crawl enabled. But even then those pages are not displayed

enitesh on Mon, 13 Feb 2017 19:50:48


As you suggested, I explicitly tried an incremental crawl. Still it didn't help.

Maruthachalam on Tue, 14 Feb 2017 04:04:43


Hi,

Here are some options/ideas to trouble shoot:

1. Check if there are any rules added to exclude these pages 

2. How much is your index size? If it is a newly created site or if has less index you can give a try deleting the index and start the crawl from the first to check if all the pages are crawled properly.  Note:Deleting the crawl is advised only if the content is less / index size is small

3. What about the other publishing pages? Other pages are displayed? Can you try creating a test publishing page, add some contents, try initiating the incremental crawl and check if the newly created page is appearing in search results

Lisa Chen1226 on Tue, 14 Feb 2017 08:21:58


Hi enitesh,

As Maruthu suggested, Check if there are any query rules to exclude these pages.

Whether all pages in the pages library can't be searched.

Navigate to the pages library->Library settings->Advanced settings->Make sure you choose "Yes" for "

Allow items from this document library to appear in search results?":

If just special page cannot be searched, try to download a copy of the page and re-upload the page to the pages library, start a full crawl and compare the results.

Best Regards´╝î

Lisa Chen

enitesh on Thu, 16 Feb 2017 15:46:09


Hi Maruthu and Lisa,

Thanks a lot for the suggestions. I managed to figure out the root cause of the issue. The property "Hide Physical Url from Search" was set to true for the pages causing issue and the Friendly URL was mapped to managed metadata. It got broken when I migrated the farm. After remapping the friendly url and doing an incremental crawl fixed the issue.

Lisa Chen1226 on Wed, 01 Mar 2017 09:24:24


Hi enitesh,

Is there anything update?

Best Regards,

Lisa Chen

enitesh on Wed, 01 Mar 2017 11:08:57


Hi Lisa,

As I mentioned above, the issue was related to friendlyurl not set. I have managed to figure out and resolve the issue.

Lisa Chen1226 on Thu, 02 Mar 2017 05:47:57


Hi enitesh,

Since your issue is solved, Please remember to mark your reply as an answer.

Have a nice day!

Best Regards,

Lisa Chen