VS2015 - no changes on solution rebuild

Category: visual studio general

Question

mattmoeller on Sun, 06 Mar 2016 00:27:49


I have a .Net 4.6 MVC project in VS2015 Enterprise. It seems that any changes I make to the solution are not picked up on rebuild/debug. If I close the solution and reopen it everything is fine. It seems like a mismatch for where IISExpress is looking for code and where rebuild is putting it?

Also, maybe related, I get a lot of debug pages that never load with repeating "the thread exited with code 0" in the logs over and over. Closing the solution and reopening seems to fix this as well.

Any ideas on how to fix this?

Thanks!

Matt


Replies

Jack Zhai-MSFT on Mon, 07 Mar 2016 07:24:44


Hi Matt,

So it just has one project in this solution, am I right?

>>It seems that any changes I make to the solution are not picked up on rebuild/debug. If I close the solution and reopen it everything is fine.

Not really debug your app, just run it using (Ctrl+ F5) start without debugging, how about the result?

(1) Please make sure that you enable the "build" option for this project under Build->Configuration manager.

(2) Enabled "Edit and Continue" option under TOOLS->Options->Debugging->General.

(3) Create a simple web app, test it again. If just the specific app has this issue, if possible, create a blank solution, and then add all project files to this new blank solution, clean and rebuild the whole solution, debug it again. At least, we could know that whether it is related to certain project files.

Best Regards,

Jack