Question

SriniSrinivas on Tue, 27 Dec 2016 09:52:14


Hi Team,

I am working with SharePoint List InfoPath form when I am open the list Customize Form and it will open in InfoPath and when I have modified the form adding new filed and publish form template in a list. After that when I open the list form template its showing old values only and showing following message

"One or more fields in the sharepoint list have changed. do you want infopath to update the set of availble fields? you may need to modify your form view to add or remove the updated fields"nks

When I click on yes button even thought the form template is not showing updated fields.

but its happening with one specific list only

what to do please help me.

Thanks


Srinivas



Sponsored



Replies

Grace WR on Wed, 28 Dec 2016 11:10:25


Hi Srinivas,

From your description, you publish the list form with InfoPath, after that, when you open the list form template it showing following message "One or more fields in the SharePoint list have changed. Do you want InfoPath to update the set of available fields? you may need to modify your form view to add or remove the updated fields”.

Per my test, If we add another columns in the list after you publish the list form with InfoPath,  the newly added columns will not be added to the InfoPath form. And you will get the message "One or more fields in the SharePoint list have changed…” when we open the form with InfoPath.

When we click on yes button the form template is not showing updated fields. We need to drag the newly added column to the form and publish it to update the form.

Best regards,

Grace Wang

Please remember to mark the replies as answers if they help.
If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


SriniSrinivas on Thu, 29 Dec 2016 11:34:46


Hi Grace Wang,

Thanks for your reply, but as you said after dragging the new filed I am publishing.

but the form template is not updating. not sure what is a issue.

Thanks

Grace WR on Fri, 30 Dec 2016 09:16:40


Hi Srinivas,

Do you publish the form template after dragging this new field?

Is there any error when you open the form template though “Customize Form” after dragging the field?

Try to go to List settings->Form settings->select “Delete the InfoPath Form from the server”:

Click “Customize Form”, check if the Form template updated.

Best regards,

Grace Wang

SriniSrinivas on Mon, 02 Jan 2017 09:00:14


Hi Grace Wang,

Wish you a happy New Year 2017.

Thanks for your reply, as per the steps you have given its updating the form template but its removing the existing content and loading with new content.

please let me know what is happening.

Thanks

Grace WR on Tue, 03 Jan 2017 09:25:06


Hi Srinivas,

If you use “Delete the InfoPath Form from the server”, then click “customize Form”, it will open with the new simple form that include the fields in the list by default.

I suggest you editing the form again by dragging fields in the Fields pane and publish it.

Best regards,

Grace Wang

Grace WR on Wed, 08 Feb 2017 07:01:06


Hi Srinivas,

How about your issue?

I am checking to see if there's anything you'd like to know, please feel free to ask us.

If the issue was resolved, you can mark the helpful post as answer, or share your solution with us.

Best regards,

Grace Wang