Question

steven_ on Wed, 20 Jan 2016 07:21:33


windows 7 sp1, no network

full install version

When I installing, there are some packages missing, i skipped them, but in the end it shows the installation fails. what should i do?



Sponsored



Replies

Weiwei Cai on Thu, 21 Jan 2016 03:32:46


Hi steven_

This forum is discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor.

Since your problem is more related to Visual Studio Installation, I help you move this thread to Visual Studio Installation and Setup forum for a better help.

Best Regards,
Weiwei

Lana Xu on Fri, 22 Jan 2016 02:10:07


Hi steven,

Thank you for posting in MSDN forum.

Since you mentioned that there is not network on your machine, I suggest you download a healthy iso image from another computer with network connection. then copy the VS iso to your machine to repair your Visual Studio 2015 Professional first.

VS 2015 iso Microsoft official download link:
https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx
VS 2015 iso files SHA-1 Values link:
https://www.visualstudio.com/en-us/downloads/visual-studio-2015-iso-sha1-vs.aspx

PS: To make sure whether your package is corrupted or not,
please use FCIV.exe http://support.microsoft.com/kb/841290  to verify hash of the ISO.
Any discrepancy would indicate that the file was corrupted. Here is a blog for how to use it, you can refer to it.

After the repair, the problem still could persist, that the cause of the issue is due to  the redistributable installer is messed up. it mixes up 64bit and 32bit dll's. You could check if you have this problem by looking at the vcruntime140.dll file size. Search your windows folder for "vcruntime140" you should see 4 files (64 and 32 bit in both release & debug versions). If any files have the same size, you need to run a repair on the redistributable.

Please refer to :

http://stackoverflow.com/questions/33855177/multiple-errors-installing-visual-studio-2015-community-edition/34008086

If the above still doesn't help, I need you installation log file to troubleshoot this issue,

please use  http://aka.ms/vscollectto gather the installation logs. After using it, you will find vslogs.cab from %temp% folder. Please upload the file to  https://onedrive.live.com/ and share the link here

Best Regards,


We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

Click HERE to participate the survey.