Question

AviSingh on Tue, 15 Apr 2014 12:01:59


Hi,

I am facing issue while i am trying to connect to the azure vitual machine. I am getting following error:

Remote Desktop can’t connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled

2) The remote computer is turned off

3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

About VM: The virtual machine is added to the virtual network. I am having some other machines on same VN, to which i am able to take RDP.

What i tried till now: 

  • Reconfigured the Endpoint for RDP on azure portal.
  • Verified that particular port is opened from my(local) machine. 
  • Restarted the azure VM(thinking that might be RDP service is not running on particular machine).
  • Since this machine was on virtual network.So i created one more VM on the same nework.Then tried with Telnet command. ex. telnet 10.0.0.4(Internal Ip) 3389(RDP port)  Failed. tried for powershell port also ex:    telnet 10.0.0.4(Internal Ip) 5986(Powershell port).

Now i can't start the RDP service on the VM(assuming RDP service is not running) through powershell because i am not able to access the machine through testvm(on same virtual network).

Please let me know the fix for this issue.

Regards,

Avinash



Sponsored



Replies

Pradeep M G on Wed, 16 Apr 2014 06:25:29


Fix RDP Settings:

Get-AzureVM –ServiceName –Name | Set-AzureVMAccessExtension |Update-AzureVM

Calling Set-AzureVMAccessExtension fixes any broken RDP settings. After the extension is enabled, to fix RDP settings in future either call the cmdlet again or restart the VM.

For this to work VMAGENT must be installed. Read this for more information.

AviSingh on Wed, 16 Apr 2014 06:54:57


Actually i created the VM 3 months back. AT the time there was no VMAgent.Now i can't install it because RDP is disabled.

Is there any other way to install it or fix this issue.

Regards,

Avinash

Vivian_Wang on Thu, 17 Apr 2014 02:59:46


Hi,

If the RDP service is stopped, we cannot remote the Virtual Machine.

So i think there is no way to remote the Virtual Machine, you should recreate the Virtual Machine.

VMAgent will install when you create the Virtual Machine.

Sorry for this.

Regards.

Vivian_Wang on Thu, 24 Apr 2014 06:32:43


Hi,

Any update?

Regards.

AviSingh on Mon, 05 May 2014 13:35:18


Tried my best but unable to resolve this issue. After some days i found that there was no connect button enabled from azure portal for that particular VM.I was not having any choice else deleting the VM.