Copy URL encoding /

Category: azure storage

Question

Tony Chilvers on Wed, 20 May 2020 07:09:56


When we want to copy a URL in storage explorer, apart from the fact the Button to do so has disapeared with the latest update, characters like a / are being encoded as %2F. While a browser should be fine, some links are being broken by this behaviour.

Can any one suggest a fix please?

Tony Chilvers

Replies

SumanthMarigowda-MSFT on Wed, 20 May 2020 07:16:55


For better understanding: Can you share the screenshot? 

Tony Chilvers on Wed, 20 May 2020 07:35:08


Thanks,I have to be careful due to the sensitivity of the content.
But lets say I have a file located a:

Root > Folder XYZ > Filename.html

When I use Copy URL, this becomes:

https://mydomain.com/Folder%20XYZ%2FFilename.html

I know spaces in filenames should be avoided, but its the / %2F that is causing problems elsewhere.

TC

Tony Chilvers on Wed, 20 May 2020 07:36:34


I should add, this has only started happening since upgrade to 1.13.0, pervious version had a Copy URL button which did not do this?

SumanthMarigowda-MSFT on Fri, 05 Jun 2020 12:17:30


Firstly, apologies for the delay in responding here and any inconvenience this issue may have caused.
 
I was looking for Storage Explorer screenshot! However If the issue still persists, I would recommend to install the latest version v1.13.1 and let me know the status. 

Latest hot fixes has been released in this version. 

Hope this helps! 

Kindly let us know if the above helps or you need further assistance on this issue.
------------------------------------------------------------------------------------------

Do click on "Mark as Answer" and Upvote on the post that helps you, this can be beneficial to other community members.