Question

Rita666 on Sun, 25 Mar 2018 19:23:08


Hey, I have a problem installing this program...

Even though the program doesn't appear installed in my programs, when I try to install it, it says there's already a version installed. 

Please help



Log File:

[0440:1AB8][2018-03-25T20:18:55]i001: Burn v3.7.3813.0, Windows v10.0 (Build 16299: Service Pack 0), path: C:\Users\Asus\Downloads\visuals\155\vc_redist.x64.exe, cmdline: ''
[0440:1AB8][2018-03-25T20:18:55]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\Asus\AppData\Local\Temp\dd_vcredist_amd64_20180325201855.log'
[0440:1AB8][2018-03-25T20:18:55]i000: Setting string variable 'WixBundleOriginalSource' to value 'C:\Users\Asus\Downloads\visuals\155\vc_redist.x64.exe'
[0440:1AB8][2018-03-25T20:18:55]i000: Setting string variable 'WixBundleOriginalSourceFolder' to value 'C:\Users\Asus\Downloads\visuals\155\'
[0440:1AB8][2018-03-25T20:18:55]i000: Setting string variable 'WixBundleName' to value 'Microsoft Visual C++ 2015 Redistributable (x64) - 14.0.24123'
[0440:1AB8][2018-03-25T20:18:55]i100: Detect begin, 10 packages
[0440:1AB8][2018-03-25T20:18:55]i000: Setting version variable 'windows_uCRT_DetectKey' to value '10.0.16299.248'
[0440:1AB8][2018-03-25T20:18:55]i000: Setting numeric variable 'windows_uCRT_DetectKeyExists' to value 1
[0440:1AB8][2018-03-25T20:18:55]i102: Detected related bundle: {d3ea57b6-46d6-4824-a20f-6b8213001903}, type: Upgrade, scope: PerMachine, version: 14.10.25017.0, operation: Downgrade
[0440:1AB8][2018-03-25T20:18:55]i108: Detected compatible package: vcRuntimeMinimum_x64, provider: Microsoft.VS.VC_RuntimeMinimumVSU_amd64,v14, installed: {8D4F7A6D-6B81-3DC8-9C21-6008E4866727}, version: 14.10.25017, chained: {FDBE9DB4-7A91-3A28-B27E-705EF7CFAE57}
[0440:1AB8][2018-03-25T20:18:55]i103: Detected related package: {8D4F7A6D-6B81-3DC8-9C21-6008E4866727}, scope: PerMachine, version: 14.10.25017.0, language: 0 operation: Downgrade
[0440:1AB8][2018-03-25T20:18:55]i108: Detected compatible package: vcRuntimeAdditional_x64, provider: Microsoft.VS.VC_RuntimeAdditionalVSU_amd64,v14, installed: {E512788E-C50B-3858-A4B9-73AD5F3F9E93}, version: 14.10.25017, chained: {21134089-9B59-34C8-BE11-929D26AD5207}
[0440:1AB8][2018-03-25T20:18:55]i103: Detected related package: {E512788E-C50B-3858-A4B9-73AD5F3F9E93}, scope: PerMachine, version: 14.10.25017.0, language: 0 operation: Downgrade
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.3 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.3 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.2 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.2 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.1 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.1 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.0 AND NOT VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i052: Condition '(VersionNT = v6.0 AND VersionNT64) AND (windows_uCRT_DetectKeyExists AND windows_uCRT_DetectKey >= v10.0.10240.0)' evaluates to false.
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: vcRuntimeMinimum_x64, state: Obsolete, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: vcRuntimeAdditional_x64, state: Obsolete, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows81_x86, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows81_x64, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows8_x86, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows8_x64, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows7_MSU_x86, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: Windows7_MSU_x64, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
[0440:1AB8][2018-03-25T20:18:55]i052: Condition 'VersionNT64 >= v6.0 OR (VersionNT64 = v5.2 AND ServicePackLevel >= 1)' evaluates to true.
[0440:1AB8][2018-03-25T20:18:55]i199: Detect complete, result: 0x0
[0440:0D24][2018-03-25T20:19:02]e000: Error 0x80070666: Cannot install a product when a newer version is installed.


Sponsored



Replies

Sara Liu on Mon, 26 Mar 2018 06:15:05


Hi Rita,

Welcome to the MSDN forum.

Please go to Control Panel-Programs and Features and if there has the Visual C++ 2017 Redistributable installed, we need to uninstall the Visual C++ 2017 Redistributable then install the VS 2015 again per this similar issue.

If not, you cannot find the higher version of the VS Visual C++ 2015 Redistributable under Control Panel-Programs and Feature, please use MsiInv to gather information about what is installed on a computer and if it is confirmed that a higher version of the Visual C++ 2015 Redistributable is existing on your computer, then you cannot install the current lower version.

Best regards,

Sara

Darran Rowe on Mon, 26 Mar 2018 08:11:51


Sara, as a suggestion, if the Visual C++ 2017 Redistributable is on a computer. Don't just suggest that they uninstall it and install the Visual C++ 2015 Redistributable.

The Visual C++ 2017 runtime is backwards compatible with the Visual C++ 2015 runtime, but the Visual C++ 2015 runtime isn't forwards compatible with the Visual C++ 2017 runtime. So by leaving it at this step, you are potentially leaving any applications that rely on the Visual C++ 2017 runtime in an unusable state. The 2017 redistributable was installed on that computer for a reason, right?

So I would suggest that you add another step to this.

Uninstall the Visual C++ 2017 Redistributable

Install the Visual C++ 2015 Redistributable

Install the latest Visual C++ 2017 Redistributable from visualstudio.com

That last step is vital for making sure that any applications that were built using Visual Studio 2017 continue working.

Sara Liu on Wed, 28 Mar 2018 08:21:53


Hi Rita,

Do you have any updates? If this issue persists, please feel free to let us know.

If it is solved, we are welcome you share the solution in here or mark the helpful reply, that will help other community members, then we can close this thread for you, thank you for your understanding.

Best regards,

Sara