Question

Superdip77 on Wed, 30 Dec 2015 14:34:04


Hello,

I have an issue with Designer in Visual Studio 2013 and 2015 (see below) . It can't load the xaml for the Windows Phone Store project... I tried  to add some rights in regedit, remove all temporary files and so on ... but I have always the issue.

If somebody has a solution, he is welcome.   

Didier

--------------------------------->

System.Runtime.InteropServices.COMException
L’application n’a pas démarré. (Exception from HRESULT: 0x8027025B)
   at Microsoft.VisualStudio.DesignTools.HostUtility.AppPackage.AppPackageNativeMethods.IApplicationActivationManager.ActivateApplication(String appUserModelId, String activationContext, ActivateOptions options, Int32& processId)
   at Microsoft.VisualStudio.DesignTools.HostUtility.AppPackage.DesignerWrtUtility.ActivateApplication(String appUserModelId, String activationContext, Object site, Boolean isRunningElevated)
   at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.ActivateApplicationInternal(String appUserModelId, String activationContext, Object site)
   at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.CreateDesignerProcess(String applicationPath, String clientPort, Uri hostUri, IDictionary environmentVariables, Int32& processId, Object& processData)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.ProcessDomainFactory.ProcessIsolationDomain..ctor(ProcessDomainFactory factory, IIsolationBoundary boundary, AppDomainSetup appDomainInfo, IIsolationTarget isolationTarget, String baseDirectory)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.ProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
   at Microsoft.VisualStudio.DesignTools.HostUtility.Platform.AppContainerProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.Initialize()
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.Primitives.IsolationBoundary.CreateInstance[T](Type type)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedObjectFactory.Initialize()
   at Microsoft.VisualStudio.DesignTools.DesignerHost.Services.VSIsolationService.CreateObjectFactory(IIsolationTarget isolationTarget, IObjectCatalog catalog)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.CreateLease(IIsolationTarget isolationTarget, CancellationToken cancelToken, DesignerServiceEntry& entry, IServiceProvider serviceOverrides)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.IsolatedDesignerService.IsolatedDesignerView.CreateDesignerViewInfo(CancellationToken cancelToken)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.InvokeWithCulture[T](CultureInfo culture, Func`2 func, CancellationToken cancelToken)
   at Microsoft.VisualStudio.DesignTools.DesignerContract.Isolation.IsolatedTaskScheduler.<>c__DisplayClass10_0`1.<StartTask>b__0()
   at System.Threading.Tasks.Task`1.InnerInvoke()
   at System.Threading.Tasks.Task.Execute()


Sponsored



Replies

Weiwei Cai on Thu, 31 Dec 2015 06:48:09


Hi Superdip77,

According to your description, this problem occurs on both VS2013 and VS 2015. Please tell us which operation system you are using. And please make sure you have installed both of Windows 8 SDK and Windows 10 SDK for your Visual Studio.

I also installed VS2013 and VS2015 in one computer (Windows 8.1 and Windows 10), both of them works fine. So there should not compatibility issue. If possible, I suggest you change another computer to check whether it also has the same problem.

Then please close all third part software when running Visual Studio, such as antivirus. And please check whether there has the same extensions installed on both of your VS, please uninstall them one by one to exclude the effect from extensions.

In addition, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

Best Regards,
Weiwei

Superdip77 on Thu, 31 Dec 2015 10:01:07


Hi Weiwei,

Thanks for your reply. I have removed VS 2013, stopped my Avast antivirus, added some rights in the register, deleted all temporary files (in the TEMP folder). I can use the designer when the project is a Windows Form project, the issue is only when is a Windows Store project.    
In the ActivityLog.xml, the last information is since the 2015/12/29

Best regards 

Didier

Weiwei Cai on Fri, 01 Jan 2016 02:00:06


Hi Superdip77,

What operation system are you using?

I also have the Design problem in my Visual Studio 2015, because I don't install the Windows 8 and Windows Phone 8/8.1 Tools for my Visual Studio 2015. Please check whether you have install that tools for your Visual Studio 2015.

Please create a WPF or Silverlight application which also XAML design, whether they are also have the same problem.

Then please make sure you have turn on the Developer Mode on Settings --> Update and Security --> For Developers menu if you are using Windows 10. And please check the event viewer for exceptions, whether there has any events logged.

Besides, the exception message you provided in original post is not English, could you please provide an English message to help us understanding the exception.

In addition, please try repair your Visual Studio with Control Panel -> Programs and Features -> Visual Studio 2015 -> Change -> Repair.

Best Regards,
Weiwei

Superdip77 on Mon, 04 Jan 2016 17:29:36


Hello Weiwei

I'm under Windows 10 Professionnal.

The english message is : "The application is not started"

I repared my VS 2015 and verified if I have all components as you can see below



I must have the option "Developers" when I'm using Windows 10 

If you have an other idea ...

Best regards

Didier

Weiwei Cai on Tue, 05 Jan 2016 01:29:29


Hi Superdip77,

Please update your Windows 10 to build 10586 from menu Start -> Settings -> Windows Update first.

If have upgraded, please check the Target version of your application, please set it as Windows 10(10.0;Build 10240)

In addition, some communities has the same problem with HP computer. If your computer also HP, please try deleting the "Platform" environment variable in System->Advanced System Settings->Environment Variables.

If none of the above helps, try to use Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx) to find out the error when your get the error in designer. And go to Event Viewer to check whether there is error. Then share the result here.

Best Regards,
Weiwei

Superdip77 on Tue, 05 Jan 2016 10:02:03


Hi Weiwei,

I have the latest version of Windows 10 as you can see below :

And I work with a GIGABYTE laptop. 

The tarket under VS is only Windows phone 8.1  

I have created a log file with the process monitor (530 Mo) how can I send you ?

Best regards

Didier

Weiwei Cai on Wed, 06 Jan 2016 01:30:23


Hi Superdip77,

Please upload the log file to OneDrive and share the link here.

In addition, please make sure whether this problem occurs with all XAML designer, for example in WPF project, Silverligh project and so on.

Best Regards,
Weiwei

Superdip77 on Wed, 06 Jan 2016 15:27:48


hi Weiwei,

WPF is ok
SilverLight is ok
Apparently the issue is only the Windows Phone Store project 

below the link of the file :

https://onedrive.live.com/redir?resid=E534B53F6BC4FFB7!2392&authkey=!AP_EygM-dJFRL0Q&ithint=file%2cPML

Best regards 

Didier

Weiwei Cai on Thu, 07 Jan 2016 05:18:57


Hi Superdip77,

According to the event log, I find that there has some error about "Name Not Found", "Invalid Parameter" under \Designer\ShadowCache folder. Please try delete this cache folder and the retry to check whether still has this problem.

If the problem still exist, please vote it and add comments in following feedback. Other communities also has this problem and post this issue to Visual Studio Connect.  I think the report team experts will evaluate this problem seriously and give us the Email update. Thanks for your feedback for the VS products.

https://connect.microsoft.com/VisualStudio/Feedback/Details/2197973

Best Regards,
Weiwei

Superdip77 on Thu, 07 Jan 2016 16:53:26


Hi Weiwei,

I removed all files in \Designer\ShadowCache folder but the issue still exist :(

I have created a feedback with using your link 

I'm installing VS 2015 on an other laptop to see if the problem is existing

Best regards

Didier

Weiwei Cai on Fri, 08 Jan 2016 02:17:18


Hi Superdip77,

Thanks for your feedback.

After installing on another computer, please feel free to come back to tell me the result.

Best Regards,
Weiwei

Superdip77 on Fri, 08 Jan 2016 06:49:38


Hi Weiwei,

On my other laptop it works perfectly :)

It is the same windows 10 professionnal and the same VS 2015 entreprise

Best regard

Didier

Weiwei Cai on Fri, 08 Jan 2016 09:21:30


Hi Superdip77,

I'm glad that it work on your laptop.

So the problem may be caused by the computer environment in that laptop. Since you have resolve your problem by re-install, please mark your reply as answer which is benefit to other communities who has the same problem.

Best Regards,
Weiwei