Question

MM from AUS on Tue, 08 Apr 2014 01:07:19


I have recently installed SQL 2012 and by default I have selected "english" as first language. When I run any statement into SQL management studio the messages outcome shows into different language

How I can change it back to English

Example

Przetworzono: 10 procent.

Przetworzono: 20 procent.

Przetworzono: 30 procent.

Przetworzono: 40 procent.

Przetworzono: 50 procent.

Przetworzono: 60 procent.

Przetworzono: 70 procent.

Przetworzono: 80 procent.

Przetworzono: 90 procent.

Przetworzono: 100 procent.


Muhammad Mehdi


Sponsored



Replies

Alberto Morillo on Tue, 08 Apr 2014 01:20:40


Hello,

Select statements will use the settings stored on the Regional Settings (Control Panel) of your computer.

Hope this helps.

Regards,

Alberto Morillo
SQLCoffee.com

Jonathan Quek on Tue, 08 Apr 2014 02:46:26


Hi,

Does this help: Tools --> Options

MM from AUS on Tue, 08 Apr 2014 03:50:41


@ Alberto Morillo

Control Panel> Regional > Language is english

MM from AUS on Tue, 08 Apr 2014 03:51:22


English already selected

Sofiya Li on Wed, 09 Apr 2014 03:23:30


Hi Muhammad Mehdi NZ,

According to your description, when you run the statements in SQL Server management studio (SSMS), the outcome messages shows into different language. If you want to change it back to English, I recommend you run the following statement.

SET LANGUAGE ENGLISH

Then it will change language of messages in SSMS.

Hope it can help you!

Regards,
Sofiya Li

MM from AUS on Wed, 09 Apr 2014 03:35:08


@ Sofiya

After I run command I got message

Changed language setting to us_english.

But when I try other syntax like recovery of database it is not in english

Przetworzono: 10 procent.

Przetworzono: 20 procent.

Przetworzono: 30 procent.

Przetworzono: 40 procent.

Przetworzono: 50 procent.

Przetworzono: 60 procent.

Przetworzono: 70 procent.

Przetworzono: 80 procent.

Przetworzono: 90 procent.

Przetworzono: 100 procent.

Sofiya Li on Wed, 09 Apr 2014 04:05:03


@ Sofiya

After I run command I got message

Changed language setting to us_english.

But when I try other syntax like recovery of database it is not in english

Przetworzono: 10 procent.

Przetworzono: 20 procent.

Przetworzono: 30 procent.

Przetworzono: 40 procent.

Przetworzono: 50 procent.

Przetworzono: 60 procent.

Przetworzono: 70 procent.

Przetworzono: 80 procent.

Przetworzono: 90 procent.

Przetworzono: 100 procent.


Muhammad Mehdi

Hi,

, you will have to use SET LANGUAGE to change the language in the above of syntax. If you have not installed the localized version of SQL Server, the default language is US English. I recommend you use the following stetament to check if you install the localized version of SQL Server.

select @@language

 If you need to change the default language on this machine, then you will have to change the default language for individual logins, as doing it on a server level won't work. For more ifnormation, see:http://www.sqlservercurry.com/2010/11/change-default-language-for-sql-server.html

Regards,
Sofiya Li

MM from AUS on Wed, 09 Apr 2014 04:51:07


It was issue only with my user login as other user did not have the same issue

I check the status of my user login and it was polish

Changed back to english

run syntax and the result into messages box is english

thanks guys for help any way