Question

sysmobile on Mon, 02 Jun 2014 17:29:57


Hi,

I'm having problems when trying to debug my Cloud service locally. I used to debug by setting my Web role project as startup project but when I try to consume it I receive this exception:

External component has thrown an exception.

               at RdGetApplicationConfigurationSetting(UInt16* , UInt16** )
   at RoleEnvironmentGetConfigurationSettingValueW(UInt16* pszName, UInt16* pszDest, UInt64 cchDest, UInt64* pcchRequiredDestSize)
   at Microsoft.WindowsAzure.ServiceRuntime.Internal.InteropRoleManager.GetConfigurationSetting(String name, String& ret)
   at Microsoft.WindowsAzure.ServiceRuntime.RoleEnvironment.GetConfigurationSettingValue(String configurationSettingName)
   at MobzillaAdNetwork.Data.DataClass..ctor() in c:\Development\AdNetworkWebService\MobZillaAdNetwork.Data\MobZillaAdNetwork.Data\DataClass.cs:line 21
   at MobzillaAdNetwork.Data.DataAccessObjects.AdDAO..ctor() in c:\Development\AdNetworkWebService\MobZillaAdNetwork.Data\MobZillaAdNetwork.Data\DataAccessObjects\AdDAO.cs:line 44
   at MobzillaAdNetwork.Control.AdCampaign.AdCampaignManager.GetAd(String token, String cookie, Int32 adSizeId, Int32 maxAdsCount, Int32 typeOfAd, String ipAddress, Int32 networkConnectionType) in c:\Development\AdNetworkWebService\MobzillaAdNetwork.Control.AdCampaign\MobzillaAdNetwork.Control.AdCampaign\AdCampaignManager.cs:line 150
   at MobZillaAdNetworkWebRole.Service1.GetAd(String token, String cookie, Int32 adSizeId, Int32 typeOfAd, Int32 maxAdsCount, Int32 networkConnectionType) in c:\Development\AdNetworkWebService\AdNetworkCloudService\MobZillaAdNetworkWebRole\MobZillaAdNetService.svc.cs:line 234
   at SyncInvokeGetAd(Object , Object[] , Object[] )
   at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
   at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
   at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
               System.Runtime.InteropServices.SEHException

While digging in to solve the problem I found everyone recommends the Cloud service project must be the startup project. When I do it that way I can not even reach the web service since when the web browser starts to browse my service I receive this error:

Error Code
   0x80070490 

Config Error
   The configuration section 'system.webServer/httpErrors' cannot be read because it is missing a section declaration  

Config File
   \\?\C:\Users\Administrator\AppData\Local\dftmp\Resources\b0849aaf-7e09-4716-9a1e-ca5be2440a4f\temp\temp\RoleTemp\applicationHost.config 

The file applicationHost.config under the path does not exist. Using IIS Express or the local IIS has the same result. I've checked users and group privileges and nothing seems out of normal. I hope you can help me, I attach a screen capture of the error

Thanks in advance.


Sponsored



Replies

Jambor yao on Tue, 03 Jun 2014 12:29:31


Hi,

If you create a simple cloud service and set the cloud project as startup project, do you receive the same issue? If this is no business with your machine environment, I suggest you check your web.config file, especially the system.webServer and httpErrors section.

Best Regards,

Jambor

SaliTech on Thu, 14 Aug 2014 18:32:14


Hi

I am struggling with similar issue with below error:

The worker process for application pool '538c3141-2078-4949-b2b9-8269b522af25' encountered an error 'Cannot read configuration file
' trying to read global module configuration data from file '\\?\C:\Users\<user_name>\AppData\Local\dftmp\Resources\2a49046f-773d-4f19-9007-a0e43f140e14\temp\temp\RoleTemp

\applicationHost.config', line number '0'.  Worker process startup aborted.

I have tried with most of the available options but no luck.

I use VS 2012 with MS Azure Tools Version 2.4

Please help me out if you have any insight in this.